What does Zig Forums think of Funtoo?

Robert Smith
Robert Smith

I been thinking to use Funtoo instead of Void.
It seemed better to learn how to use Portage.
Does Funtoo really work alot better or should I use Gentoo?
Is there any Funtoo users who use it?
I'm some guy who uses LMMS to make music anyways & also plays HL2 Deathmatch all night when I get tired.

Attached: qwe-download.png (20.64 KB, 165x100)

Other urls found in this thread:

raw.githubusercontent.com/damentz/liquorix-package/5.0/linux-liquorix/debian/config/kernelarch-x86/config-arch-64
wiki.gentoo.org/wiki/Distributions_based_on_Gentoo
cloveros.ga
cloveros.ga/s/nodbus/),

Thomas Allen
Thomas Allen

funtoo has debian kernels and some more profiles
other than that, there's no real difference between funtoo and gentoo as far as I know
It seemed better to learn how to use Portage.
you'll have to read the gentoo documentation anyway
(although the funtoo wiki is good for what it has, they have some neat guides and tutorials on general linux stuff, checking it out might be worth it)
funtoo is only good f you care about the additional profiles that it provides imo
if you want to use debian kernels instead of doing genkernel or manually configuring the kernel on gentoo, you can just copy the debian kernel config (or any other distro's for that matter)

Thomas Myers
Thomas Myers

I considered using Funtoo because configuring a kernel manually is my least favorite part of managing a Gentoo system. But eventually, I got my kernel config exactly the way I liked it, and changing from Gentoo to Funtoo just for a simplified kernel process would be a major waste of time at this point.

Just use "genkernel --menuconfig all" at first, skipping the manual configuration until your system is stable.

Chase Evans
Chase Evans

yikes

Austin Ward
Austin Ward

Funtoo is the easymodo of Gentoo (well, i guess CloverOS is even easier). In Funtoo, a lot of USE flags can be set (and finetuned) via eselect. But, imo, if you don't have a reason to use Funtoo, you should just run Gentoo or CloverOS because Gentoo has larger community.

I advice against using genkernel for configuring and compiling the kernel. You can also just grab the kernel binary from a LiveCD (or extract it from a deb package). Configuring the kernel doesn't require much work at all once you have configured it once (just do a make syncconfig when you upgrade)
Also, a ProTip: rember to emerge the gentoo-sources with symlink USE flag enabled.

Alexander Ward
Alexander Ward

Configuring the kernel doesn't require much work at all once you have configured it once
that was more my point - that kernel configuration should come secondary to getting a working system booted and configured. at least for a new gentoo user who has never configured a kernel once, because it will just take up a lot of their time and often results in unbootable kernels. which leads to dropping gentoo altogether.

genkernel is just the Gentoo wiki supported way of saying "i don't care about kernel configuration for now" but there's definitely other ways of doing that.

Noah Evans
Noah Evans

HL2 Deathmatch is god tier

Jaxon Miller
Jaxon Miller

You can easily grab a major kernel config and have Genkernel use it:

wget raw.githubusercontent.com/damentz/liquorix-package/5.0/linux-liquorix/debian/config/kernelarch-x86/config-arch-64
genkernel --kernel-config=config-arch-64 all

Attached: 2019-05-14-125444-2560x1440-scrot.png (1.2 MB, 2560x1440)

Elijah Thompson
Elijah Thompson

pedo detected

Blake Hughes
Blake Hughes

It's like gentoo but better.
git > rsync

James Barnes
James Barnes

Can one install Gentoo with genkernel as their first installation and later go through the configuration in the same installation, just changing the kernel?

Gavin Martinez
Gavin Martinez

ok hagcuck

Luke Lewis
Luke Lewis

of course, you can even use binary kernel
however, genkernel really enables lots of extra configs, lengthening compile time

Christian Jones
Christian Jones

gentoo can use git too though, no?

Hunter Clark
Hunter Clark

It's Gentoo with some very specific quirks and less dev time allocated to it. I used it in the past and as my first "Gentoo" system for a few years before migrating the config to Gentoo when some annoyances turned up.
The biggest difference for most newish Gentoo users is splitting the Gentoo portage tree into a bunch of independent overlays called kits so you have some semblance of a versioned distro. There's also some shortcuts for setting up a new system, like the simpler network configuration and the defaulting to a Debian kernel.
It sounds nice on paper but for a desktop/workstation system it just means you're using Gentoo with slightly outdated packages and a much, much smaller support base. I think it's better suited as an more conveniently deployed (over Gentoo) VM distro for specific applications.

Yes but on a new installation you'll have to emerge-webrsync first, emerge git and then change repos.conf to use git, maybe nuke the rsynced tree first also. Not sure if Funtoo has commit signature verification but on Gentoo it's advisable to enable via 'sync-git-verify-commit-signature = true' in repos.conf.

Dylan Rivera
Dylan Rivera

Funtoo has preset use flags if you don't want to configure every binary. If you don't want to configure any binary, there's CloverOS.

Attached: gentoo.jpg (6.48 MB, 4160x3120)

Elijah Rivera
Elijah Rivera

Is there a quick way of installing Gentoo that doesn't requiring compiling?

Luke Collins
Luke Collins

why would you install it then.. it wont be the same if you use precompiled shit

Oliver Sullivan
Oliver Sullivan

Only machine I have is an Eee PC with an Intel Atom.

Carter Gutierrez
Carter Gutierrez

Clover OS isn't just a meme?. What advantages does it have?. You sure it's not backdoored?. Little leery of anything made by 4chan.

Owen Edwards
Owen Edwards

You can use a general kernel, but you will have to compile other parts of the system. Here is a list of gentoo derivative distros, see if any of them catch your eye wiki.gentoo.org/wiki/Distributions_based_on_Gentoo

I'm looking for a classic thinkpad thats 13 inches and under in monitor size, but not the palm ones from the 486 days. Anyone got a good reccomendation thats relatively recent? I'm thinking 2003+

Attached: holytindermittens.png (546.28 KB, 820x498)

Joshua Murphy
Joshua Murphy

gas me, i thought this was thinkpad general

Robert Lee
Robert Lee

There’s a lot of different distros on that list. I’m a beginner, what would you recommend? I know some Linux, I got a Linux essentials cert, but I feel like I don’t even know enough to build my own webserver.

Jonathan Martin
Jonathan Martin

In my experience, I've only tried out Calculate Linux and Sabayon. Sabayon worked well, the last time I tried it back in 2014. I would imagine it would work fine. It does deviate from base gentoo because of their own repos and release schedules. I only had problems with AMD drivers, but since you said you're using an EEEPC, there's not a concern there. Calculate Linux should function fine, just be aware of its eastern european origins and there are issues with encryption not working working on Calculate, last I heard. If you still want to do Gentoo, I would highly reccomend going through the handbook. If you follow it all the way through you should be fine. If compiling is still a concern, I would reccomend testing out the other pre-compiled derivatives. Lastly, there are stage 4 tarballs, but to my knowledge these are made as bootable images to install gentoo onto a hard drive.

Nicholas Bailey
Nicholas Bailey

I've used it for years. It's a great distro with very sane defaults.

David Price
David Price

I was going down the linux migration path earlier today (due to sheer boredom) and realized that the kernel still doesn't have proper 802.11AC support (beyond a single chipset). How are people managing? Do you guys not use AC or 5GHz Wifi at all?

Zachary Miller
Zachary Miller

Do you guys not use AC or 5GHz Wifi at all?
yes.
Why would i want to anyway?

Justin Reyes
Justin Reyes

To prevent 2.4GHz interference?

Oliver Rodriguez
Oliver Rodriguez

It's just an easy mode Gentoo with aggressive optimization AFAIK. You can read about it at cloveros.ga

Jose James
Jose James

Attached: gentoo.jpg (6.75 MB, 3120x3641)

Jaxson Thompson
Jaxson Thompson

CloverOS is a meme. It has no full disk encryption option during it's installation. So what's the point using it then?

Kayden Reed
Kayden Reed

It also has dbus in the binary package host despite being an anti-poetteringware/freedesktopware distro.

Adam Russell
Adam Russell

Only a few packages (DEs) actually pulls it in

Xavier Garcia
Xavier Garcia

That's not true since glib, a very common dependency, is built with dbus

Jordan Torres
Jordan Torres

It's also built without dbus. When glib is updated on systems with no dbus-dependant packages, it updates with the glib without dbus.

Cooper Gomez
Cooper Gomez

Only the livecd is built with packages from the nodbus binhost (cloveros.ga/s/nodbus/), meaning, anytime glib is updated on a full installation of cloveros, dbus is installed as well.
Basically, you'll end up running dbus sooner or later.

Pic related is on a fresh installation.

Attached: jesus.png (13.97 KB, 1156x828)

Jonathan Lewis
Jonathan Lewis

if you update with ./cloveros_settings.sh u, one of the commands it runs is echo Removing dbus if possible...; for i in {dev-libs/glib,dev-qt/qtgui,dev-python/PyQt5,xfce-base/thunar}; do [ -d /var/db/pkg/$i* ] && sudo PORTAGE_BINHOST="cloveros.ga/s/nodbus" FETCHCOMMAND_HTTPS="wget -O \"\${DISTDIR}/\${FILE}\" \"\${URI}\"" emerge -1uD $i; done; sudo emerge --depclean which will update glib and remove dbus if you don't have packages that explicitly require dbus.

It's a quick solution that works and keeps every package available.

Anthony Green
Anthony Green

Why should I have to use a sloppily put together script that breaks the standard interface for updating packages on gentoo? A better solution would be to produce two separate portage profiles to accommodate systems with and without dbus.

William Parker
William Parker

The script is fine. The command removes dbus.

You could also get the portage files with ./cloveros_settings.sh c and edit the packages.use and build yourself.

Henry Brooks
Henry Brooks

You're forgetting that dbus is pulled during system updates regardless. It's just that the script removes dbus after the fact.
Also, the script edits user configuration in the zz case, and removes the distfiles cache and build logs for failed emerges in 9 case which may not be desirable. The zz and 9 cases are both called by u.
Take a look at the way pentoo does things, they don't need an ad-hoc script because they use portage profiles instead.

and edit the packages.use and build yourself.
I already manage my own package.use :^)

Michael Carter
Michael Carter

A better solution would be to produce two separate portage profiles to accommodate systems with and without dbus.
Your asking for him to do something smart. he's not interested in managing a dbus free veriant of gentoo, he just wants to pose as an ultra hipster on cuck/g/ shove is crappy glued together stage4 everywhere and larp like he's hot shit.
cloveros is just his own personal setup and he never had or has any interest in not using dbus as that would inconvenience him too much.

Aaron Robinson
Aaron Robinson

What is the purpose of dbus and what is the difference between a system with dbus and another system without dbus? What kind of programs would I be unable to use?

Attached: Favelitoarmado.png (24.43 KB, 200x168)

Ethan Turner
Ethan Turner

A bunch of shitware refuses to run without dbus which limits your software choices in FOSS to better software unless you start patching it out or compiling it yourself, and even then.

The only thing dbus actually does that you use is enable shutdown/retart/hibernate icons you can press and do the selected thing. Without dbus there is no way to do that as a user, you must be root or write something to interface with HAL to enable shutdown/etc for normal users. Dbus also allows udisks2 to automount disks for you, but you could use udevil and a udisk1 enabled GUI to bypass that. Just symbolic link udisk to udevil and done since udevil is a drop in replacement. Doesn't work for udisks2 though.

There's other things dbus does that take up resources and that you don't use. Such as allowing a network enabled program to send arbitrary commands to programs you have running at a C API level. Like if you had a function DESTROY_COMPUTER() in a C program that had dbus/introspection enabled on it you could call that c function over a network socket from china or from a second user on your machine. Removing this anti-feature reduces program size and allows the compiler to optimize the program better. Ontop of reducing the security risk of such.

Its an IPC, it does what a network enabled IPC is meant to do.

Gabriel Butler
Gabriel Butler

That doesn't change the fact the CloverOS iso doesn't have dbus and it's easily removed.

Cooper Fisher
Cooper Fisher

it just werks(tm)
So does systemd. Hell, so does windows. Why would you spend all this time creating a "distro" if you can't bother to do things properly?

Brody Gray
Brody Gray

the creator is a underage mentally ill attention whore. thats why.