Icecat Updated to v60.5.0ESR

New modifications to the git
git clone git://

Other urls found in this thread:!topic/

Following what posted. I've successfully compiled Icecat 60.5.0ESR for GNU/linux debian based distros.
Warning tho this version isn't finished yet, it hasn't been released on the gnu ftp.
I'm working on Trisquel so I didn't had much dependencies to begin with.
You need at least 20GB of disk space to compile this, at the end the folder will weight 9.6GB.
RTFRM!: The readme in the new git version is not correct follow the old one

>cd objdir/browser/locales

First install the essential:
Then install the dependencies for your firefox fork, on Trisquel we don't have firefox but abrowser:
On my distro I had to install another few dependencies that were not satisfied, I had to install bzr, mercurial, devscripts and ccache:
Normally it should just compile fine with these if you have more dependencies then you need to find them.

Now do:
Go into the folder:
You now need to let the makefile "makeicecat" to be executable:
Now execute the makefile:

As stated in the README, the file that it will generate will be put in the "output" folder.
Now you need to fetch the build script to build Icecat for the platform that you want:
In this example we'll compile it for GNU/linux based distros, so you need first to make it executable:
Then you need to copy it to the output folder where the Icecat source were made:
Then go in your icecat-60.6.3 folder.
Once you're in it you need execute the "" script.
You'll have to wait for a few hours depending on the hardware that you have.
After that you have two options, the first being to install it directly, the second is to create a tarball.
I haven't done a direct installation with "make install" but only the tarball.

As mentioned in the README, for the tarball go to the folder "installer located in "~/gnuzilla/output/icecat-60.6.3/obj-gnulinux/browser/"
Once in it you just have to do "make"
Again like the README says, the tarball will be located in "~/gnuzilla/output/icecat-60.6.3/obj-gnulinux/dist".
So go in it:
And you'll find a tarball named "icecat-60.6.3.en-US.linux-x86_64.tar.bz2".
Of course it could have another name if you fidled with the l10n options (options to compile with another language).
If you want to change language you aren't force to recompile everything the XPI file for that are located in "~/gnuzilla/output/icecat-60.6.3/obj-gnulinux/dist/linux-x86_64/xpi".

This should work on old versions of icecat too. I'm going to try and compile for windows since I still have fam on it. Good luck anons.


Hope it'll compile on Devuan, because previous releases didn't. That's the only reason I'm using furryfox now...

Attached: big_bob_gerl_hai.jpg (1793x2689, 697.28K)

how long does it take to compile this? it wasnt that bad before rust but i have not tried compiling it after that was added

Please try and post what happened, I hope it compiles well. Normally it should, Trisquel is Debian/ubuntu based with a lot more restrictions than Devuan so if it compile on Trisquel it compiles on pretty much anything.

Like said in the post a few hours, it varies depending on your hardware.
I had worse, the first time that I compiled gentoo took much longer than that.

Is this the version that adds the new rust based layout engine and is meant to be super fast?

m8 Firefox implemented that functions one or two years ago, and it's not because of rust that it's fast it's because their re-written the whole CSS rendering engine from scratch, they could have done it in C or any other language it would have been fast too, it was just because the CSS code was bad.
Rust is a meme language, don't trust the hype.
If you want to see if ff is fast just compare icecat 38 and the latest one.

So after attempting to compile for windows I ran into an obstacle.
In the "buildscripts" folder I need to first build the tools chain to be able to cross compile for windows from gnu/linux and to put it simple the doesn't work and gives errors. I suppose it's because it is outdated.
Last support version of Icecat for windows was v38 so there's loads to catch up.
I'm going to look into the unofficial compiled version on github maybe there's an working version there.

In the buildscripts folder the "mozconfig-windows" seems outdated.
It states that the sandbox can't be built with mingw-w64 but in the URL the bug is stated as fixed.
The option "ac_add_options --disable-sandbox " doesn't exist anymore either.

why use Icecat when you can use Tor Browser?
and why Icecat doesn't use Tor?

Because some people don't use the Tor network.

It use similar options like fingerprinting protection.

you can use tor proxies with icecat. but you cant browse on tor networks.

Tor browser is a fork of Firefox and is dedicated to make it easy to join the Tor network. It is a matter of convenience. You can configure any browser (such as Icecat) to make use of Tor.

This is true but many websites using the tor node list block your browser/client if you don't use the tor browser headers for everything. The idea was originally to block wget and crawlers but evolved into banning anything that isn't tor browser from tor. Cloudfare is one such example for websites that don't change their settings correctly. As it blocks you on tor unless you use the tor browser settings for: user agent, platform agent, image referrer agent, accept headers, and javascript OSCPU. It may or may not block you if you don't disable things like canvas ID and javascript. You should all be using text browsers or the single browser that you can unpozz, firefox forks. Actually I really should just release a meme browser for shitz and giggles. I need logos though for all the files located under . I also need some faggot who can compile the crapshoot for faggot osx and windoze as I can't be assed to compile it for such because unix sucks but the alternatives eat shit.

If you're interested in an open source project, just make your first release for one platform and any other developer who is interested will take their own time to compile it for the other platforms.

I haven't find anything on the icecat-win64 github.
I posted the error that seems related to GAS on searx engines, the solutions that I read was to get a more recent version of GCC but I've already tried four different versions and it doesn't work.

Here are the errors that I get

In the file I've changed the wget lines, and other corresponding, to see if it would work with another version of GCC, it works but I still have the same errors.

For shit and giggles I've launched the "" and of course it didn't work
I'm kinda blocked right now. Will continue research later.
Maybe the simplest way would be to compile icecat under windows?

So mainline has been updated to 60.5, but when does this come to the ftp

When they decided that it's stable.

It seems that the script hasn't been updated since 2016, the same year that windows compatibility was drooped.

Well I've looked into the Icecat mailing list, sadly the links that existed for cross-compiling icecat for windows are 504.
Both links are dead.
I've found this link which compiled a version of Icecat 45.7 on windows.
It really grinds my gears that you have to use visual studio to compile for windows.


Someone that has access to embargoed mozilla CVEs can you make the more then year old CVEs on this list public or post the patch fixes for all of them with fixes? I wanted to compile an older version of it with these backported so it doesn't get hacked as easily.

embargo is cancer and needs to die. if the jews can know about it then other should know too so they can do something to it

This would be very productive.

All of this is either outdated or not working on Trisquel.
I get
When I launch the Bootstrap script.
I found a similar thread for gentoo but it's seven years old

The absolute difference between compilation guides for Gnu/linux and Windows.

Linux Prerequisites:
Linux build preparation:
These were maybe recently updated but don't work on blobless debian/ubunt based system, compare these to the windows build manual and you see that they are incomplete or less learning friendly, even the Icecat Readme was more precise than this.

This is the sort of easy to learn steps.

Building Firefox On Windows:


Any news ? Did it work ?

I found this

>This is my first attempt at building a Windows binary of GNU IceCat. Please see for more information.

>I began with instructions from Mozilla for setting up a build environment:

Seems that cross compile is doomed for now.

Link related ? Trisquel 8 uses Gcc 5.4.

so why do you want this on windows so much?

When you want to migrate your users to another OS they need to have the most similarity looking software available.
Having Icecat or other software on their windows workstations before I migrate them to gnu/linux is always better for them and me, as they won't come crying that they don't recognize the software they are using.
Either you change the softwares they use without the OS or you change the OS without changing the software but you don't do both at the same time. You can of course do both at the same time but it has a higher chance of going badly for your users.

What is the point of all the meme extensions? Just give it uMatrix you retards.

9999 out of 10000 people are too retarded to understand it, and it's not much higher among modern Zig Forums posters. That's why most people here unironically use google chrome.

Icecat was made for users to avoid proprietary Javascript.
If you don't like libreJS deactivate it and install umatrix.

Tbh libreJS needs to mimic what umatrix does. A grid that automatically block nonfree JS and that can be customized like umatrix would be a neat grail.

Thanks user, it works great, removed almost all addons I had before. I was too lazy to check what uMatrix is, but that was a mistake.

Dependency hell on windows is hell worse than gnu/linux.
Basically this guide is incomplete and the isn't working for icecat.

I went like this
Then you need to install the MozillaBuild which is a terminal with bash functions
Once that's done go in c:\mozilla-build\ and launch that terminal then do
Launch the script that will install the remaining dependencies
./mach bootstrap
From that point I thought if the dependencies are satisfied then I can just do what and . I'll just download the icecat source copy the mozconfig and launch "./configure" then "./mach build"
But no the ./configure gives me an error.
And yes you have to install LLVM no it's even stated in the
Ok lets install LLVM, there's no instructions from mozilla on to how to do it.
which version of python ? idk installed 2.7
Install cmake
Git clone llvm
>git clone
Build LLVM and Clang:
Open a new windows terminal (not the mozilla one)
and it doesn't work
You can now go back and also try the and it won't work either it gives you errors.

>viewboard=!', 'clone', '--noupdate', '

It unironically might be easier to install gentoo and then make a mingw32 crossdev enviroment to compile icecat then that shit. See for the idea or more resources.
Three commands and done, the binary shows up under /usr/i686-w64-mingw32/usr/bin/ . That is after you install gentoo which is its own ordeal. This is assuming no problems crop up. It sounds alot easier then dealing with microsoft's compiler and other such shit. Clang/gcc optimize better too.

Ya'll niggas need to find Jesus. And MSYS2.

I have installed gentoo in the past and I agree I had less much ==BULLSHIT== if not none when installing gentoo than compiling on wintrash.
How do developers work on that piece of shit ?

Don't we already have Saint-iGNUcius ?

so why is this still not on the gnu ftp?

Mozilla has literally millions of dollars and can't even educate there developers to make propos documentation.

it all goes to very important things like supporting feminism and diversity. to them its more important to hire a tranny nigger than fix the software

IceCat 60.7.0 released!

slightly off topic but how do i remove the pre-embedded extensions on icecat properly?

i've found that the `extensions/gnu` has all the extensions and deleted the directory but once the build reaches that stage it gives an error.
i managed to modify the thing that `mach install` reads to install the thing and removed the addon check thingy so it installed properly.

what's the proper way to do this?