Zig Forums Questions and Support

Bring all your hardware, software and other troubles here.

Attached: questionmark.png (200x200, 2.82K)

Other urls found in this thread:

freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames/
tech-otaku.com/linux/getting-cisco-packet-tracer-71-to-run-on-ubuntu-1604-lts/)
security.ubuntu.com/ubuntu/pool/main/i/icu/libicu52_52.1-3ubuntu0.7_amd64.debsudo
blog.emsisoft.com/en/28620/antimalware-service-executable/
docs.python.org/3/
raspberrypi.org/blog/why-raspberry-pi-isnt-vulnerable-to-spectre-or-meltdown/
github.com/gorhill/uMatrix/issues/32

Alright might as well free it, I am a fan of FOSS. It's just that I'm not a programmer, and my code is most likely eye-garbage to anyone who is. But it works, and it'd be nice to see others use it.

Too late.

Also, any recommendations for a better language with IDE for future projects?

Thanks for the input btw

there is nothing there, it should be somewhere on the USB, but where and what are the file(s) called?

try `ls /sys/class/net/` and see what it lists. you should have `lo` which is loopback and then some others. check those others with ethtool.

Why doesnt this CSS validate on my board?

/*Links*/a, a:visited {text-decoration: underline;color: #FFFFFF;}/*Background of page*/body{background-image: url('');background-color: #000000;background-repeat:no-repeat;background-position: right center;color: #FFFFFF;}/*Top banner of page with listed boards*/div.boardlist {color: #FFFFFF;}.desktop-style div.boardlist:nth-child(1) { position: fixed; top: 0px; left: 0px; right: 0px; margin-top: 0px; z-index: 30; box-shadow: 0px 1px 2px rgba(0, 0, 0, 0.15); border-bottom: 1px solid; background-color: #000000;}/*Post Menu*/.post-menu li:hover {background-color: #000000;color: #FFFFFF;}.post-menu li {background-color: #03C03C;color: #FFFFFF;}/*Page title and subtitle*/header div.subtitle, h1 {color: #03C03C;text-align: center;}/*Posting mode banner*/div.banner {background-color: #03C03C;font-size: 12pt;font-weight: bold;text-align: center;margin: 1em 0px;}div.banner, div.banner a {color: #FFFFFF;}/*Reply post comment formatting*/div.post.reply {background: none repeat scroll 0% 0% #000000;border-width: 1px;border-style: solid solid solid solid;}div.post.reply {border-color: #FFFFFF;}div.post.reply.highlighted {background: none repeat scroll 0% 0% #000000;/*border-color: #03C03C*/}/*Animated post reply highlight*/div.post.reply.highlighted { border-color: #03C03C; -webkit-animation: mymove 5s infinite; /* Chrome, Safari, Opera */ animation: mymove 5s infinite;}@-webkit-keyframes mymove {50% {border-color: blue;}}/* Chrome, Safari, Opera */@keyframes mymove {50% {border-color: blue;}}/* Standard syntax *//*Reply post link formatting*/div.post.reply div.body a {color: #03C03C;}/*Reply post quote formatting*/.quote {color: #FFB347;}/*Redtext formatting*/span.heading {color: #FF6961;font-size: 11pt;font-weight: bold;}/*Spoiler formatting*/span.spoiler {background: #FFFFFF none repeat scroll 0% 0%;color: #FFFFFF;padding: 0px 1px;}/*Post subject*/p.intro span.subject {color: #AEC6CF;font-weight: bold;}/*Post name*/p.intro span.name, .own_post {color: #03C03C;font-weight: bold;}/*Post table formatting*/form table tr th {background: none repeat scroll 0% 0% #000000;border-width: 1px;border-style: solid solid solid solid;border-color: #FFFFFF;} td {background-color: #000000;}/*Section seperating lines formatting*/hr {border-color: #FFFFFF -moz-use-text-color -moz-use-text-color;}/*Bottom Page navigation Selector formatting*/div.pages{border-right: 1px solid #FFFFFF;border-bottom: 1px solid #FFFFFF;border-top: 1px solid #FFFFFF;border-left: 1px solid #FFFFFF;background: none repeat scroll 0% 0% #000000;}div.pages a.selected {color: #FFFFFF;font-weight: bolder;}/*Catalog Page Threads*/.theme-catalog div.thread {border-right: 1px solid #FFFFFF;border-bottom: 1px solid #FFFFFF;border-top: 1px solid #FFFFFF;border-left: 1px solid #FFFFFF;background: none repeat scroll 0% 0% #000000;}/*Rules and other pages formatting*/div.ban{background-color: #000000;color: #FFFFFF;background: url('') repeat-x scroll 50% 0% #000000;border: 1px solid #03C03C;}div.ban h2{background-color: #03C03C;color: #FFFFFF;}/*------alternate background---------body{background-color: #003E82;color: #FFFFFF;background: url('') repeat-x scroll 50% 0% #003E82;}*/

Attached: 1521348979959.gif (512x481, 645.6K)

Nevermind, it works now.
Anybody know any tricks to alter the CSS to do simple things? Like if I wanted to change the background?
t. noob

I've tried it on other OS, changed the port and it still did not work, I also tried VPN.

Should I try maccy d's internet?

Have you tried using encryption?

Uncomment and edit the last couple lines

I'musing wingblows 10 and there is a process called "Antimalware service executable" that is always eating 50% of my cpu. I can't even stop it.

Any ideas?

Attached: Asari-Codex-ME3.jpg (256x256, 74.45K)

install gentoo

>freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames/


Makes sense to me; why did he say as if it's something bad?

users should be setting their own device names based off of hardware identifiers instead of relying on a developer's preference. this doesn't help with that.

Not him but its retarded. How is a string of characters that seemingly came from /dev/random more predictable then eth#. I do recognize the problem hes trying to solve but he is solving it poorly. Once again we just need to look at OpenBSD for the right solution which is name network devices based on the driver they use. This way the number isn't related to when the driver gets loaded. Of course OBSD also solved this in another way in that they don't have modules that get loaded in a random order based on braindead design.

Don't be a faggot

t.tripfag

It's not random. For example mine in enp5s0
en: Ethernet
p5: PCI bus 0x5
s0: Slot 0x0

If you know what PCI bus your embedded ethernet controller or wifi radio is on, you might be autistic.

Attached: you-might-be.jpg (534x712, 41.42K)

can you read English?

You can use "lspci" or just directly get the current interfaces with "ip link"
ifconfig is deprecated

How would one go about unlocking a bootloader and rooting an android over Linux these days? Everything I find is related to (((kingoroot))) or requires windows. And why is every root manager closed source?

It's been awhile since I've done it but pretty much all of it is done with adb, which will natively run on Linux.
And Lineage has it's own built in root manager that's floss.

I needed Packet Tracer 7 for uni so I installed it on my Xubuntu 16.04.3 LTS machine. After I installed it I couldn't start it. I read that I needed to install some missing packages so I ran:
sudo apt-get install libqt5webkit5 libqt5multimedia5 libqt5printsupport5 libqt5script5
It still didn't start. Then I read here (tech-otaku.com/linux/getting-cisco-packet-tracer-71-to-run-on-ubuntu-1604-lts/) that I needed to install an older version of an existing package, so I ran:
wget security.ubuntu.com/ubuntu/pool/main/i/icu/libicu52_52.1-3ubuntu0.7_amd64.debsudo dpkg -i libicu52_52.1-3ubuntu0.7_amd64.deb
Packet Tracer started up, but the entire application seemed almost comically large. I thought that the issue was only in Packet Tracer so I decided just to put up with it. But today I went to start up a VirtualBox VM and again the entire application was scaled to a ridiculous size. I decided to uninstall what I installed yesterday so I ran:
sudo apt-get purge libqt5webkit5 libqt5multimedia5 libqt5printsupport5 libqt5script5sudo dpkg -P libicu52:amd64sudo apt-get autoremove
Both Packet Tracer and VirtualBox are still scaled too large. I restarted my machine just to be sure but it didn't change anything.
Anyone know what I can do to fix it? Any help is greatly appreciated.

Attached: kermit.png (195x195, 32.66K)

check the DPI settings for your X server and DE

blog.emsisoft.com/en/28620/antimalware-service-executable/

All DPI settings are the same as they were, nothings changed

Scaling issues are only with Qt applications, obviously because I was installing Qt packages.

check your environment variables for qt scaling

I tried changed two environmental variables to the following values and tested VirtualBox each time but nothing changed.
export QT_SCALE_FACTOR=1export QT_DEVICE_PIXEL_RATIO=1
export QT_SCALE_FACTOR=0export QT_DEVICE_PIXEL_RATIO=0
export QT_SCALE_FACTOR=0.5export QT_DEVICE_PIXEL_RATIO=0.5

What I'm doing is different. They are animations that the creator only uploads as gif, not gifs of a video. Since they're simple animations I can run the frames through waifu2x and get something that looks good. I want to make those images into a video, but I have color problems.
yuv444p didn't seem to change anything, does it need to be in any specific position in the command? Here's an example of what I'm using:
ffmpeg -start_number 0 -i %06d.png -b:v 16M out.mp4

I was under the impression that you would put the color profile and filters before the -i of each file.

Will installing gentoo actually teach me anything or is it just a meme? Am I better off doing Linux From Scratch?

Attached: 1477282397416.jpg (750x750, 161K)

Installing a distro to "learn." Please don't think this way, personally I find it very annoying. Regardless of the distribution you should be constantly learning. As a former user of LFS for over a year I can summarize that you pretty much just learn what ./configure flags do. That's something you can learn on any distribution of GNU/Linux. As a user of gentoo for coming close to 4 months, I would highly recommend using it. I feel it really captures the idea of free software in the way that their package manager works. For example, it makes it simple to make modifications to the programs you are installing. This allows you to easily exercise your right to modify the software, and not have to worry about the package manager.

Can an OpenBSD user please post their fstab? In particular, I want to know how to automount a msdos file system (to /mnt).
Yes, I've read the man page. It's the one time they have failed me.

it's not a color profile, it's pixel format.
it must go before the output file but after input.

btw for the sake of experiment also try `rgb24`

also don't use bitrate control for video encoding, use -crf instead. it is more efficient and you exactly set the quality level instead of getting (unpredictable quality and almost-but-not-quite predictable file size)

and if this is a simple drawing, maybe even lossless mode would be better.

I got it. rgb24 didn't have the color problems. Thanks for the tip about crf. I ended up using 18 because 0 was much larger and looked the same.
Here's what I ended up using:
ffmpeg -start_number 0 -i %06d.png -c:v libx265 -pix_fmt rgb24 -crf 18 out.mp4

I'm writing a bash script to optimize image files based on their mimetypes. What I have now works, but I'd like for it to do certain mimes before others instead of each file alphabetically, because png takes a lot longer than jpg.
Should I use an array? I was thinking I could put the faster mimes at the beginning of the array and the slower ones at the back. Is this a good idea or am I retarded?

what if you replace rgb24 with yuv444 now?
and play with a proper player like mpv or vlc

I'm asking because while rgb24 may be slightly more accurate, it compresses really badly by x264/x265 because they won't do any further channel decorrelation. and I have never seen cases where the color space conversion alone (without any fucking subsampling) would do any dramatic visible changes.

also, check for updates of ffmpeg, maybe yours has a bug that got fixed later.

yuv444p

give up on bash and write in python
you'll spend less time even if you don't know it yet, bash is "write-only" language as soon as you need something bigger than trivial. you'll also end up with more robust code (less failing corner cases)

I've already deleted my source files, but I did yuv444p with those options and it still messed the colors up. A darker orange became a yellow-orange. I compared the first frame of the mp4s to the first image of the source files and the rgb24 looked identical to me, so I kept it. The filesize of the rgb24 mp4 was smaller than any one of the original frames, so I'm happy with that.
I have the latest version of ffmpeg, 3.4.2.

btw did you try only with x265?
could be a x265-specific problem I guess.

I added the bit about x265 when I added crf, before I didn't specify and just let it choose whatever it does by default for a .mp4.

Can I get some pointers for single layer pcb component placement? Is auto routing simply unreliable and I should go ahead and do it manually? Is it possible for this many ICs and a 20x20 board?

Attached: pcb.png (891x835, 95.63K)

Auto routing works pretty well and is a good tool to know. There won't be any problems with it for your circuit provided it can find a solution.
You could reduce the amount of ICs you are using by using a microcontroller.

I'd like to see if it can be done without a microcontroller(even though at this point it would cost less, especially with the 74185s).
I figure at this point the way to go is to bridge anything that isn't connected, but I'd like to minimize said bridges as much as possible and truth be told I have zero idea as to what constitutes good part placement and at the moment I'm moving shit haphazardly.

I have no room for a second hard drive in my desktop case, it's a Compaq Presario. Is there any way to fix this or am I just shit out of luck?
Pic related is NOT my own PC but it gives you a good idea of what it does look like. Can I just put it in a random place and attach SATA cables to it? I realise this might come off as a retarded question to some but I have no experience with this kind of stuff. I also realise my PC is quite old but I have become attached to it so I'd rather not replace it.

Attached: forum.jpg (635x480, 57.59K)

Just put some double sided tape on it and put it somewhere random, if you don't intend to move your PC at all you can even leave it waggling.

No battery, volume or brightness on the live image of cloveros.
normal or just live image quirk?

Attached: c1d5d9fdd476cb2ca6f0043963f4ad1c25d596276179723fccf306ab1e13f4d5.png (1368x768, 49.97K)

You have a couple options

Does anyone know how to set up an external gpu on the cheap?
I want to take a gpu for around 50-60 bucks and hook it up to my desktop.
Does anyone know of anything with compatibility I should be looking for or if I have to upgrade to win10.

I have Amd Quad Core with integrated graphics. But the integrated graphics are pretty crap so I want to upgrade it with a new gpu but the case is too small.
Product recommendations, advice, guides?

yeds

I don't plan on it. So your answer is yes, learning anything by installing gentoo is merely a meme, good to know

answer my question i want to escape systemd botnet but want everything to work once installed

Install and find out

I don't want to waste my time actually installing it and finding out it doesn't work. I'm just wondering if this is the case for other people

is it a spinning disc or solid state drive? if you are up for case modding, i would say take everything out, cut some ports for SATA and power cables to go through, file the ports down, paint, then have your drive sitting on top of your computer. you could even get some sheet metal and form an enclosure on top of the case. or do as these anons said and

Normal I think, the default is just a wm but you can install xfce or which has this stuff.

bigger case

Is there any decent search engine?
Googl is >google.
Duckduck is made by a data mining company.
Startpage is the best of the three, but there's the gay fucking family filter that you need scripts just to disable.

Attached: a6f22007668c9901be9f624b53689daa-imagepng.png (720x717, 601.87K)

Startpage lets you create a custom URL with certain settings, like disabling that filter

So it's just a bug? It's supposed to show but it doesn't?

Qwant, Searx. DuckDuckGo is still less shit than Google.

Is the EOMA-68 affected by meltdown or spectre?
I want to get a good machine for some dedicated shitposting and using it for camera's in my house.

Please help me fix my fucked up mouse Zig Forums.

A kind user on /v/ posted some handy dandy tools for overclocking my logitech B100 mouse on Win7. The driver setup required a couple of security certificates that I failed to install beforehand, so it didn't work. Anyway, I tried the setup again and decided to press a button called "Restart."This erased the device (the mouse) from the list and made it undetectable in Device Manager. Even after multiple restarts it continues to do this, even though it makes an audible sound that it's connected. I've been looking for solutions online but I can't find anything similar to this problem.
Figured I broke the mouse somehow but when connecting it to a different computer it works flawlessly right off the bat.

I-I just wanted to play some Deus Ex.

Attached: 9214733969bc0d82e300acc7ecc237d556d4b53090e1b3c51ecc39deec2c6068.png (800x800, 154.01K)

Does it show as "undefined" device? Download drivers from website or whatever windows updater spits at you once again after connecting from device manager tree.

Short answer:
Any of them accessed over not your home IP address and with turned off javascript/click tracking. DDG and Startpage are just Yahoo and Google proxies anyways.
Long answer:
Sometimes it's better to spend 2 seconds on Google or Yandex than trying to create an arcane spell that won't give absolute normalfag clickbait answers in your Startpage search. Sometimes it's vice-versa though, Google became shittier in terms of algorithms last few years and is absolutely unpredictable.
And forget searching for obscure electronics datasheets without submitting to Baidu botnet.

use the System Restore tool

Thanks for the tip, it was showing up as "USB input device" or something instead of "HID-compliant Optical Wheel Mouse," different section too.
I've been at it for over two hours trying to find this cunt.
Thanks user!

How many layers is your pcb?

(nice numbers)
I think it might be less complicated to stick with bash. I've never used a real programming language before, and can't figure out how to run a unix command on each of the input files like I'm used to.
If I do end up with Python I'll need a good guide, does Zig Forums have any recommendations or should I just fucking look it up?

docs.python.org/3/

searx. They even have a link near the result for viewing the page through a sanitized (they remove ads and tracking stuff) proxy.

How are you currently doing it? If you are just doing it by images/* you could do images/*.jpg images/*.png images/*.gif.

Here's what my script does, I can paste the whole thing if you want.
It doesn't rely on the extension because sometimes they're wrong. Maybe in a future version I'll add a bit to change/add an extension if it doesn't match.
I do have an older version that uses extensions and it does go in the right order, but again it can be wrong. I guess I could run a double check mimetype before running the command, but it could get ugly.

hey everybody you should answer this guy's post :DDDDDDDDDDD

It's not affected by either I think. The A20 they use is a ARM Cortex-A7 which is what rpi3 uses and they are not affected.
raspberrypi.org/blog/why-raspberry-pi-isnt-vulnerable-to-spectre-or-meltdown/

How do i obtain true anonymity? What browser should i use and what addons should i install, i know HTTP everywhere and Ublock but what else. Also my friend told me to use discord a few days ago, and im worried if someone might be able to find where i was posting/logging on from before.

What would be a good distro for gayman considering these specs?
Both with and without wine.

Attached: ClipboardImage.png (510x401, 18.29K)

Windows

Does anyone know what's the most up to date 3d human anatomy atlas?

and do you have a magnet for it?

Single layered. I asked around and a double layer isn't that expensive so I might just get that instead, but I'd like to persist and gain whatever experience I can from this.

I would highly recommend using a double layered one so you can have traces on both sides. This allows you to use vias to go from the top layer to the bottom layer making routing a lot easier.

But then you can't search from the URL form.

If I really need something I'll try the other search engines, but I just want one for general use with a chance not to track me.


SearchX sounds good, thanks.
Have some robutt since that's the most Zig Forums related lewds I have right now.

Attached: 4c6b4d1c9b173e591fa9460962fec326d246944063705d2f7930c11a9686e021.webm (800x1200 326.55 KB, 165.57K)

I never noticed that. Have an extra lewd since I wanted to post 5.

Attached: 375408d0b32a7e539c923a45847968e5171132fd2ba912cc7db298aa3b3d1ef1.gif (1000x1500 645.95 KB, 253.87K)

Tor with security slider set to high, stop using chrome, discord, win10 or other proprietary software. Block scripts with noscript or so.

...

Decentraleyes, uBlock Origin and uMatrix are important addons. Avoid any browser based on WebKit or Blink, only use Firefox or Firefox based browsers. Your best option is IceCat or Tor.
Don't use discord. It's malware. A much better and private VOIP client is Mumble. If you need a social platform IM then use Riot.im, or Wire/Signal Messenger.
Avoid non-linux OSs, or any proprietary software.

Not the guy who asked the question, but isn't that redundant, or is there something uMatrix doesn't block but uBlock does and vice-versa?

github.com/gorhill/uMatrix/issues/32
If you don't want uMatrix, keep PrivacyBadger and Decentraleyes. But uMatrix can be used to bypass anti-adblock scripts which uBlock can't.

I already have uMatrix, I just just wondering if there was any benefit to using uBlock as well.
From that thread, it seems that it's mostly just ease of use and more specific blocks.

How do I block pol.css on 8ch.net/pol/ using Ublock Origin?

first you need to understand that it's not possible, and you should pick a realistic goal.
true anonymity is only possible if you're a single cell organism flying in outer space with insane speeds and you're completely identical to ∞ another organisms densely packed around you. and still you could be tracked when some more advanced tech becomes available.

dont browse pol

Can you not change the theme, or are you talking about something else?

The smug nazi lolis

I guess I'll go with removing the DVD drive for now then.

Just use ublock origin

Think of Ublock as a tool for removing html elements. Just blocking ads from loading might still leave a blank space that was allocated to put an ad in. You can also use it to remove other obtrusive html elements.